Nach Update auf Windows 10: Kein Zugriff auf die Datenbank

Setup von ACT! 7-21, Installation auf Servern und Workstations, Anpassungen und Einstellungen, SQL-Server und ACT!

Moderatoren: Schlesselmann, Ingrid Weigoldt, Thomas Benn, Amrou, mtimmermann, Robert Schellmann

Antworten
V. Heitmann
Beiträge: 83
Registriert: Donnerstag 22. September 2005, 09:15
Wohnort: 61169 Friedberg
Kontaktdaten:

Nach Update auf Windows 10: Kein Zugriff auf die Datenbank

Beitrag von V. Heitmann »

Ein PC mit Windows 8.1 wurde gestern automatisch auf Windows 10 upgedatet. Seitdem lässt sich ACT! 2013 (Version 15) zwar starten. ABER: Die Datenbank lässt sich nicht öffnen. Es kommt eine Fehlermeldung, dass kein Zugriff auf die Datenbank möglich ist. Man solle die Netzwerkverbindung und die Verfügbarkeit des Datenbankservers prüfen. Wenn diese Fehlermeldung mit OK quittiert wird, kommt eine weitere Meldung, dass der Objektverweis nicht auf eine Objektinstanz festgelegt wurde.

Ich habe den Windows Defender und unsere Antivirensoftware (Kaspersky Internet Security) ausgeschaltet bzw. beendet. Das bringt aber keine Besserung.
Was ist da schiefgegangen, was kann ich tun?
Grüße aus der goldenen Wetterau,

Volkmar Heitmann

V. Heitmann
Beiträge: 83
Registriert: Donnerstag 22. September 2005, 09:15
Wohnort: 61169 Friedberg
Kontaktdaten:

Beitrag von V. Heitmann »

Das Problem konnte inzwischen (fast) vollständig gelöst werden: Zuerst über eine Neuinstallation von ACT! einschließlich der SQL-Datenbank.

Dann trat der Fehler auch auf einem zweiten PC auf, der diesmal von Windows 7 auf Windows 10 aktualisiert worden war. Hier kam zusätzlich eine Fehlermeldung, die ausnahmsweise einmal recht hilfreich war: "Der SQL-Server konnte nicht gestartet werden." Kein Wunder also, dass ACT! keinen Zugriff auf die Daten bekam.

Der SQL-Server (Microsoft SQL Server 2008 Express Edition SP1) wurde dann einfach manuell neu gestartet (über die Windows-Dienste-Verwaltung). Anschließend funktionierte ACT! (fast) wieder ganz normal.

ABER: Sowohl nach der Neunistallation, als auch nach dem manuellen Start der Datenbank erscheint trotzdem noch und jedes Mal wieder die schon oben beschriebene Fehlermeldung "Der Objektverweis wurde nicht auf eine Objektinstanz festgelegt", nachdem ACT! beendet wurde.

Mit dieser Fehlermeldung kann man natürlich leben, zumal ACT! ansonsten ja normal zu arbeiten scheint. Trotzdem bleibt ein ungutes Gefühl, dass da irgendetwas noch nicht ganz in Ordnung ist.

Weiß hier jemand von den Experten, was die Ursache für die Fehlermeldung "Der Objektverweis wurde nicht auf eine Objektinstanz festgelegt" sein könnte und wie man sie abstellen kann?

Ich freue mich auf hilfreiche Antworten!
Grüße aus der goldenen Wetterau,

Volkmar Heitmann

Amrou
Beiträge: 59
Registriert: Montag 5. September 2011, 14:28

Beitrag von Amrou »

Weiß hier jemand von den Experten, was die Ursache für die Fehlermeldung "Der Objektverweis wurde nicht auf eine Objektinstanz festgelegt" sein könnte und wie man sie abstellen kann?
Der Hersteller scheint diese Meldung zu kennen (betrifft nur Windows 10). Diese sollte keine Auswirkung auf ACT! Funktionalitäten haben.
Issue: Error: “Object reference not set to an instance of an object when exiting Act!
There is currently no workaround for making this error stop appearing, however the error has not been found to halt any functionality in Act! and can be disregarded.
Gruß
Wassim Amrou
Bild KundenInfo - für mehr Infos in Ihrem ACT!

V. Heitmann
Beiträge: 83
Registriert: Donnerstag 22. September 2005, 09:15
Wohnort: 61169 Friedberg
Kontaktdaten:

Beitrag von V. Heitmann »

Danke für die Rückmeldung! Das bestätigt meine Vermutung und ist beruhigend.

Im Großen und Ganzen scheint ACT! 15 (2013) also Windows-10-tauglich zu sein.
Grüße aus der goldenen Wetterau,

Volkmar Heitmann

Antworten