ACTForum.de Foren-Übersicht

Das deutschsprachige Forum für ACT!

betrieben von Melville‑Schellmann
FAQFAQ SuchenSuchen MitgliederlisteMitgliederliste BenutzergruppenBenutzergruppen RegistrierenRegistrieren
ProfilProfil Einloggen (private Nachrichten)Einloggen (private Nachrichten) LoginLogin
Die letzten 20 Posts im ACTForum.de

Companion über Connect // fehlende Registry Keys

ACTForum.de Foren-Übersicht -> ACT! 7-21 - Installation von ACT!
Neues Thema eröffnen Neue Antwort erstellen
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Au­tor Nachricht
Heiko Grethe



Anmel­dungs­datum: 23.05.2018
Bei­trä­ge: 3

BeitragVerfasst am: Do Mai 24, 2018 9:31 am    Titel: Companion über Connect // fehlende Registry Keys Antworten mit Zitat

Ausgangssituation:
1. Neu installiertes ACT! Premium 20
2. Installation "ACT! Connect Link Setup 1.1.13"
3. Auf Android ACT! Companion installiert
4. In ACT! den LINK für ACT! Connect abgerufen
5. Eingabe Login-Daten auf Mobilgerät
6. Eingabe https://XXXXX.g2c.cloud-elements.com/act.web.api sowie Datenbank

Ergebnis: Fehlermeldung "Überprüfen Sie, ob die Server-URL korrekt ist".

Prüfung: beim Aufruf des Links über einen Browser kommt eine detailliertere Meldung:

Line 50: <identity impersonate="true" password="registry:HKLM\Software\AspNetProcess\ASPNET_SETREG,password" userName="registry:HKLM\Software\AspNetProcess\ASPNET_SETREG,userName" />

Diese Registry-Keys gibt es aber gar nicht auf dem ACT!-Server. Sie werden offensichtlich weder bei der Installation von ACT! Premium, noch beim ACT! Connect angelegt.

Können die Keys manuell nachgetragen werden (wenn ja, welche Werte?) oder muss gegebenenfalls doch die WEB-Variante von ACT! installiert werden, damit über ACT! Connect mit dem Companion gearbeitet werden kann?
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden
Robert Schellmann



Anmel­dungs­datum: 14.04.2001
Bei­trä­ge: 1669
Wohnort: Hamburg

BeitragVerfasst am: Mi Mai 30, 2018 2:03 pm    Titel: Antworten mit Zitat

Hallo Herr Grethe,

kann es sein, dass Sie auf dem Server nicht "ACT! Premium" sondern "ACT! Premium for Web" installiert haben?

Wenn ja, ist die Act.Web.API als virtueller Ordner im IIS-Server installiert.

Sie müssen dann, die Datenbank über den Menüpunkt "Extras"-"Website-Verwaltung..." (Act! zuvor "als Administrator starten") für die beiden Web-Front-Ends freigeben. Dabei muss ein Windows-Admin-Login hinterlegt werden (Registerkarte "Benutzerkonto"). Erst dann funktioniert die spezielle Act.Web.API Variante im IIS-Server.

Tipp: Wenn Sie eine Act.Web.Api testen wollen, können sie das mit der folgenden Adresse: https://...cloud-elemts.com/act.web.api/api/system

Hier ein Beispiel-Link auf unseren ACT! for Web-Demoserver:
https://www.servicetransparent.de/act.web.api/api/system

Als Antwort sollte man eine Versionsinformation im Json-Format bekommen:

apiVersion "1.0.279.0"
sdkVersion "20.0.159.0"


Gruß
Robert Schellmann
_________________
MSControl4 - wird Ihre ACT!-Daten zum Rotieren bringen...
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen
Heiko Grethe



Anmel­dungs­datum: 23.05.2018
Bei­trä­ge: 3

BeitragVerfasst am: Mi Mai 30, 2018 3:09 pm    Titel: Danke Herr Schellmann! Antworten mit Zitat

Ja, die Installation ist mit "ACT Premium for WEB" durchgeführt worden, aber die WEB-GUI sollte eigentlich noch nicht freigeschaltet werden, daher der Wunsch, nur die Connect-Schnittstelle zu nutzen...

So hat es sofort geklappt! Die vorher angemeckerten fehlenden Registry-Keys sind weiterhin nicht da, aber das System erlaubt den Zugriff.

(... und wenn man die Spracheinstellung im ACT! Companion auf "English" stellt, dann kann auch ACT! Insight genutzt werden...)
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden
Robert Schellmann



Anmel­dungs­datum: 14.04.2001
Bei­trä­ge: 1669
Wohnort: Hamburg

BeitragVerfasst am: Mi Mai 30, 2018 3:49 pm    Titel: Antworten mit Zitat

Hallo Herr Grethe,

es kann sein, dass es ausreicht, wenn man in der "Website-Verwaltung..." nur das Benutzerkonto einrichtet und noch keine Datenbank für die Web-Frontends freischaltet.

Freud mich, dass es funktioniert, und sogar die plattdeutschen "Act!-Einsichten" werden sichtbar... ...

Gruß
Robert Schellmann
_________________
MSControl4 - wird Ihre ACT!-Daten zum Rotieren bringen...
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen
Heiko Grethe



Anmel­dungs­datum: 23.05.2018
Bei­trä­ge: 3

BeitragVerfasst am: Fr Jun 01, 2018 10:36 am    Titel: The ASP.NET user account does not have permissions to access Antworten mit Zitat

In einem zweiten System kommt es bei der Eingabe des Windows User Account zu einer Fehlermeldung. Egal welche Rechte der Benutzer hat, der eingetragen wird: Lokaler Administrator, Domain Administrator, Installations-User für ACT!: immer kommt die Meldung:

"The ASP.NET User account does not have permission to access or run ACT! Premium."

Dort musste noch ASP.NET 3.5 (2.0) installiert werden.
Anschließend in der Registrierung die Berechtigung für folgende Schlüssel anpassen:
HKLM\Software\WOW6432Node\ASPNETPROCESS\ASPNET_SETREG
Hier benötigt der Benutzer "NETZWERKDIENST" das Recht "LESEN"
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden
Beiträge der letzten Zeit anzeigen:   
Neues Thema eröffnen Neue Antwort erstellen Alle Zeiten sind GMT + 1 Stunde
ACTForum.de Foren-Übersicht -> ACT! 7-21 - Installation von ACT!
Seite 1 von 1

 
Gehe zu:  
Du kannst keine Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum nicht antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.


Powered by phpBB © phpBB Group
Deutsche Übersetzung von phpBB.de
Betreiber: Melville-Schellmann