Companion über Connect // fehlende Registry Keys

Setup von ACT! 7-21, Installation auf Servern und Workstations, Anpassungen und Einstellungen, SQL-Server und ACT!

Moderatoren: Schlesselmann, Ingrid Weigoldt, Thomas Benn, Amrou, mtimmermann, Robert Schellmann

Antworten
Heiko Grethe
Beiträge: 3
Registriert: Mittwoch 23. Mai 2018, 17:47

Companion über Connect // fehlende Registry Keys

Beitrag von Heiko Grethe »

Ausgangssituation:
1. Neu installiertes ACT! Premium 20
2. Installation "ACT! Connect Link Setup 1.1.13"
3. Auf Android ACT! Companion installiert
4. In ACT! den LINK für ACT! Connect abgerufen
5. Eingabe Login-Daten auf Mobilgerät
6. Eingabe https://XXXXX.g2c.cloud-elements.com/act.web.api sowie Datenbank

Ergebnis: Fehlermeldung "Überprüfen Sie, ob die Server-URL korrekt ist".

Prüfung: beim Aufruf des Links über einen Browser kommt eine detailliertere Meldung:

Line 50: <identity impersonate="true" password="registry:HKLM\Software\AspNetProcess\ASPNET_SETREG,password" userName="registry:HKLM\Software\AspNetProcess\ASPNET_SETREG,userName" />

Diese Registry-Keys gibt es aber gar nicht auf dem ACT!-Server. Sie werden offensichtlich weder bei der Installation von ACT! Premium, noch beim ACT! Connect angelegt.

Können die Keys manuell nachgetragen werden (wenn ja, welche Werte?) oder muss gegebenenfalls doch die WEB-Variante von ACT! installiert werden, damit über ACT! Connect mit dem Companion gearbeitet werden kann?

Robert Schellmann
Beiträge: 1673
Registriert: Samstag 14. April 2001, 02:00
Wohnort: Hamburg
Kontaktdaten:

Beitrag von Robert Schellmann »

Hallo Herr Grethe,

kann es sein, dass Sie auf dem Server nicht "ACT! Premium" sondern "ACT! Premium for Web" installiert haben?

Wenn ja, ist die Act.Web.API als virtueller Ordner im IIS-Server installiert.

Sie müssen dann, die Datenbank über den Menüpunkt "Extras"-"Website-Verwaltung..." (Act! zuvor "als Administrator starten") für die beiden Web-Front-Ends freigeben. Dabei muss ein Windows-Admin-Login hinterlegt werden (Registerkarte "Benutzerkonto"). Erst dann funktioniert die spezielle Act.Web.API Variante im IIS-Server.

Tipp: Wenn Sie eine Act.Web.Api testen wollen, können sie das mit der folgenden Adresse: https://...cloud-elemts.com/act.web.api/api/system

Hier ein Beispiel-Link auf unseren ACT! for Web-Demoserver:
https://www.servicetransparent.de/act.web.api/api/system

Als Antwort sollte man eine Versionsinformation im Json-Format bekommen:

apiVersion "1.0.279.0"
sdkVersion "20.0.159.0"


Gruß
Robert Schellmann
Bild MSControl4 - wird Ihre ACT!-Daten zum Rotieren bringen...

Heiko Grethe
Beiträge: 3
Registriert: Mittwoch 23. Mai 2018, 17:47

Danke Herr Schellmann!

Beitrag von Heiko Grethe »

Ja, die Installation ist mit "ACT Premium for WEB" durchgeführt worden, aber die WEB-GUI sollte eigentlich noch nicht freigeschaltet werden, daher der Wunsch, nur die Connect-Schnittstelle zu nutzen...

So hat es sofort geklappt! Die vorher angemeckerten fehlenden Registry-Keys sind weiterhin nicht da, aber das System erlaubt den Zugriff.

(... und wenn man die Spracheinstellung im ACT! Companion auf "English" stellt, dann kann auch ACT! Insight genutzt werden...)

Robert Schellmann
Beiträge: 1673
Registriert: Samstag 14. April 2001, 02:00
Wohnort: Hamburg
Kontaktdaten:

Beitrag von Robert Schellmann »

Hallo Herr Grethe,

es kann sein, dass es ausreicht, wenn man in der "Website-Verwaltung..." nur das Benutzerkonto einrichtet und noch keine Datenbank für die Web-Frontends freischaltet.

Freud mich, dass es funktioniert, und sogar die plattdeutschen "Act!-Einsichten" werden sichtbar... :o ...

Gruß
Robert Schellmann
Bild MSControl4 - wird Ihre ACT!-Daten zum Rotieren bringen...

Heiko Grethe
Beiträge: 3
Registriert: Mittwoch 23. Mai 2018, 17:47

The ASP.NET user account does not have permissions to access

Beitrag von Heiko Grethe »

In einem zweiten System kommt es bei der Eingabe des Windows User Account zu einer Fehlermeldung. Egal welche Rechte der Benutzer hat, der eingetragen wird: Lokaler Administrator, Domain Administrator, Installations-User für ACT!: immer kommt die Meldung:

"The ASP.NET User account does not have permission to access or run ACT! Premium."

Dort musste noch ASP.NET 3.5 (2.0) installiert werden.
Anschließend in der Registrierung die Berechtigung für folgende Schlüssel anpassen:
HKLM\Software\WOW6432Node\ASPNETPROCESS\ASPNET_SETREG
Hier benötigt der Benutzer "NETZWERKDIENST" das Recht "LESEN"

Antworten